未來 WooCommerce 6.5 版本的新要求:最低 PHP 7.2+

未來 WooCommerce 6.5 版本的新要求:最低 PHP 7.2+

從計劃於 2022 年 5 月發布的 6.5 版開始,WooCommerce 將需要 PHP 7.2 或更高版本才能運行。

為什麼會發生這種變化?

PHP 生態系統正在迅速發展。在撰寫本文時,唯一積極維護的 PHP 版本是 8.0 和 8.1;截至 2021 年 12 月,PHP 7.4 進入 “僅安全修復” 模式,PHP 7.3 不再受支持。出於性能和安全原因, WordPress 建議至少使用 PHP 7.4 ,而這些原因在電子商務網站上更為重要。

WooCommerce 還依賴於許多第三方軟件包——其中許多軟件包正在逐漸放棄對舊 PHP 版本的支持。 這已經引起了問題,因為越來越難找到支持從 7.0 到 8.1 的所有 PHP 版本範圍的軟件包。

為什麼是 7.2?根據我們的數據,這是仍然有大量 WooCommerce 安裝運行的最舊版本:

如果我不升級會怎樣?

請注意,在 PHP 7.0 或 7.1 上運行的所有站點中,似乎只有大約一半是積極維護的——也就是說,運行最多六個月的 WooCommerce 版本。

如果您的服務器在 WooCommerce 6.5 發布時仍使用 PHP 7.0 或 7.1,您的 WooCommerce 實例將繼續工作,但您將無法升級到 WooCommerce 6.4(或之後發布的任何 6.4.x 維護版本)。

我們強烈建議將您的服務器升級到至少 PHP 7.4,以確保您的 WooCommerce 站點保持最新、高性能和安全。

文章沒看懂?代碼不會用?需要幫助您可以去論壇提問自助服務台

作者風間

在哪裡跌倒,就在哪裡趴着。